1 (edited by fatty0 2011-04-30 05:08:51)

Topic: Package does not match intended download

All day today i have been unable to install any packages from the repository, I get the following error:

(2/11): php-common-5.3.6-3.el5.remi.x86_64.rpm                                                         | 973 kB     00:03
http://remi-mirror.dedipower.com/enterp … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(2/11): php-common-5.3.6-3.el5.remi.x86_64.rpm                                                         | 973 kB     00:03
http://iut-info.univ-reims.fr/remirpms/ … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(2/11): php-common-5.3.6-3.el5.remi.x86_64.rpm                                                         | 973 kB     00:02
http://remirpm.mirror.gymkl.ch/enterpri … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(2/11): php-common-5.3.6-3.el5.remi.x86_64.rpm                                                         | 973 kB     00:02
http://rpms.famillecollet.com/enterpris … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.

everything was working perfectly yesterday...


I am running CentOS 5.6...

Re: Package does not match intended download

Try a "yum clean all".

Desktop: Fedora 21 x86_64 + rpmfusion + remi-test + remi-dev
Laptop: Fedora 20 x86_64
Hosting Server: CentOS 6.5 (Santiago) x86_64 + EPEL + remi + remi-php56

Re: Package does not match intended download

tried that, and no luck...

Re: Package does not match intended download

I just retried it:

[root@xxxxxx ~]# yum clean all
Loaded plugins: allowdowngrade, fastestmirror, priorities
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@xxxxxx ~]# yum install php
Loaded plugins: allowdowngrade, fastestmirror, priorities
Determining fastest mirrors
* base: mirror.5ninesolutions.com
* centosplus: mirror.5ninesolutions.com
* contrib: mirror.hmc.edu
* epel: mirror.hmc.edu
* extras: mirrors.usc.edu
* remi: iut-info.univ-reims.fr
* rpmforge: ftp-stud.fht-esslingen.de
* updates: mirror.hmc.edu
base                                                                                                                          | 2.1 kB     00:00
base/primary_db                                                                                                               | 2.2 MB     01:04
centosplus                                                                                                                    | 1.9 kB     00:00
centosplus/primary_db                                                                                                         |  59 kB     00:01
contrib                                                                                                                       |  951 B     00:00
contrib/primary                                                                                                               |  204 B     00:00
epel                                                                                                                          | 3.7 kB     00:00
epel/primary_db                                                                                                               | 3.7 MB     00:02
extras                                                                                                                        | 2.1 kB     00:00
extras/primary_db                                                                                                             | 241 kB     00:00
remi                                                                                                                          | 2.5 kB     00:00
remi/primary_db                                                                                                               | 258 kB     00:01
rpmforge                                                                                                                      | 1.1 kB     00:00
rpmforge/primary                                                                                                              | 2.2 MB     00:04
rpmforge                                                                                                                                 10499/10499
updates                                                                                                                       | 1.9 kB     00:00
updates/primary_db                                                                                                            | 400 kB     00:00
Reducing Red Hat Enterprise 5 - RPMforge.net - dag to included packages only
Finished
343 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.3.6-3.el5.remi set to be updated
--> Processing Dependency: php-cli = 5.3.6-3.el5.remi for package: php
--> Processing Dependency: php-common = 5.3.6-3.el5.remi for package: php
--> Running transaction check
---> Package php-cli.x86_64 0:5.3.6-3.el5.remi set to be updated
--> Processing Dependency: libedit.so.0()(64bit) for package: php-cli
---> Package php-common.x86_64 0:5.3.6-3.el5.remi set to be updated
--> Running transaction check
---> Package libedit.x86_64 0:2.11-2.20080712cvs.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================
Package                            Arch                           Version                                        Repository                    Size
=====================================================================================================================================================
Installing:
php                                x86_64                         5.3.6-3.el5.remi                               remi                         1.4 M
Installing for dependencies:
libedit                            x86_64                         2.11-2.20080712cvs.el5                         epel                          80 k
php-cli                            x86_64                         5.3.6-3.el5.remi                               remi                         2.6 M
php-common                         x86_64                         5.3.6-3.el5.remi                               remi                         973 k

Transaction Summary
=====================================================================================================================================================
Install       4 Package(s)
Upgrade       0 Package(s)

Total download size: 5.0 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): libedit-2.11-2.20080712cvs.el5.x86_64.rpm                                                                              |  80 kB     00:00
(2/4): php-common-5.3.6-3.el5.remi.x86_64.rpm                                                                                 | 973 kB     00:03
http://iut-info.univ-reims.fr/remirpms/ … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(2/4): php-common-5.3.6-3.el5.remi.x86_64.rpm                                                                                 | 973 kB     00:02
http://remirpm.mirror.gymkl.ch/enterpri … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(2/4): php-common-5.3.6-3.el5.remi.x86_64.rpm                                                                                 | 973 kB     00:03
http://remi-mirror.dedipower.com/enterp … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(2/4): php-common-5.3.6-3.el5.remi.x86_64.rpm                                                                                 | 973 kB     00:02
http://rpms.famillecollet.com/enterpris … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/4): php-5.3.6-3.el5.remi.x86_64.rpm                                                                                        | 1.4 MB     00:04
http://iut-info.univ-reims.fr/remirpms/ … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/4): php-5.3.6-3.el5.remi.x86_64.rpm                                                                                        | 1.4 MB     00:03
http://remirpm.mirror.gymkl.ch/enterpri … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/4): php-5.3.6-3.el5.remi.x86_64.rpm                                                                                        | 1.4 MB     00:03
http://remi-mirror.dedipower.com/enterp … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(3/4): php-5.3.6-3.el5.remi.x86_64.rpm                                                                                        | 1.4 MB     00:02
http://rpms.famillecollet.com/enterpris … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(4/4): php-cli-5.3.6-3.el5.remi.x86_64.rpm                                                                                    | 2.6 MB     00:07
http://iut-info.univ-reims.fr/remirpms/ … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(4/4): php-cli-5.3.6-3.el5.remi.x86_64.rpm                                                                                    | 2.6 MB     00:04
http://remirpm.mirror.gymkl.ch/enterpri … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(4/4): php-cli-5.3.6-3.el5.remi.x86_64.rpm                                                                                    | 2.6 MB     00:04
http://remi-mirror.dedipower.com/enterp … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.
(4/4): php-cli-5.3.6-3.el5.remi.x86_64.rpm                                                                                    | 2.6 MB     00:04
http://rpms.famillecollet.com/enterpris … x86_64.rpm: [Errno -1] Package does not match intended download
Trying other mirror.


Error Downloading Packages:
  php-common-5.3.6-3.el5.remi.x86_64: failure: php-common-5.3.6-3.el5.remi.x86_64.rpm from remi: [Errno 256] No more mirrors to try.
  php-cli-5.3.6-3.el5.remi.x86_64: failure: php-cli-5.3.6-3.el5.remi.x86_64.rpm from remi: [Errno 256] No more mirrors to try.
  php-5.3.6-3.el5.remi.x86_64: failure: php-5.3.6-3.el5.remi.x86_64.rpm from remi: [Errno 256] No more mirrors to try.

[root@xxxxxx ~]#

Re: Package does not match intended download

Please try again.

There is a issue with metadata generated under fedora 15.
I have regenerated the metedata from fedora 14, seems ok now.

Thanks for the report.

Desktop: Fedora 21 x86_64 + rpmfusion + remi-test + remi-dev
Laptop: Fedora 20 x86_64
Hosting Server: CentOS 6.5 (Santiago) x86_64 + EPEL + remi + remi-php56

Re: Package does not match intended download

Did another clean all and now it works!

Thank you!

Re: Package does not match intended download

For memory : https://bugzilla.redhat.com/500364

Desktop: Fedora 21 x86_64 + rpmfusion + remi-test + remi-dev
Laptop: Fedora 20 x86_64
Hosting Server: CentOS 6.5 (Santiago) x86_64 + EPEL + remi + remi-php56